TNS-12560: TNS:protocol adapter error

 时间:2026-04-21 15:48:54

1、1.检查自己的服务器名  

[oracle@iZbp11f71l9kcj49jvnng9Z ~]$ hostname

2、2.经常用云服务镜像,恢复后未改服务器名,会出现这个问题

3、3.lsnrctl status

无法启动信息

4、4.lsnrctl start

也不能工作

5、5.仔细 (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=

这里服务器名不一致

6、5.$ORACLE_HOME

找到oracle的安装目录

7、找到安装目录后,在后面加/network/admin,就可以找到 listener.ora位置

/u01/app/oracle/product/11.2.0/db1

/u01/app/oracle/product/11.2.0/db1/network/admin

8、然后编辑用 listener.ora,记得

改成localhost

参考如下:

 (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=localhost)(PORT=1521)))

9、保存后,在运行lsnrctl start,lsnrctl status,现在是不是可以正常运行了呢,可以看参考图

Good lucky

  • xshell如何修改编码类型
  • NotePad++ 怎么把一列/数行 数据转成一行
  • 使用pl/sql 怎么导出dmp文件
  • impdp导入dmp文件
  • MobaXterm怎么开启使用右键单击粘贴
  • 热门搜索
    一厢情愿什么意思 燕山运动 麻仁丸的功效与作用 黄马甲运动 什么是金融学 地理七年级上册知识点 石膏的功效与作用 破折号的作用有哪些 什么是债券基金 葱头的功效与作用